Mail intermittently bouncing from Microsoft-owned domains (outlook.com & hotmail.com)

Resolved
Operational
Started about 3 years ago Lasted 11 days

Affected

Email Hosting services
Email servers
Updates
  • Resolved
    Resolved

    After two support different cases with Microsoft, they've finally resolved their issue which was on their end and was accidentally blocking all mail from my email servers to Microsoft-owned domains such as @outlook.com and @hotmail.com and @live.com.

    A workaround was put in place immediately on the 15th when I became aware of the issue to avoid any large impacts. Now that Microsoft has permanently fixed the issue on their end, I have been monitoring it for the last few hours today and all appear to be okay again using the regular delivery methods instead of the workaround, there were no failed deliveries to Microsoft-owned domains. This issue is now considered resolved.

    Please note that while the workaround had been in place since the 15th to ensure deliverability to all domains, the workaround meant that if any messages were bounced from the receiving end (i.e. typo in the email address for example), the bounce-back messages would not be sent to your emails meaning you'd be unaware if it failed to deliver. When I reviewed the logs for the last few days, I could not find any failed deliveries so I don't believe there were any failures. However, in the very rare event that the recipient of your email mentions they never received it, simply re-send the message and it will work again successfully. And if it fails, you'll at least get a bounce-back message notifying you of the failure and why it failed, which you can forward on to me if you need any assistance.

    If there are any questions or concerns with this incident that occurred on Microsoft's side, please don't hesitate to reach out to me.

    Thank you for your continued trust.

    Dustin.

  • Monitoring
    Update

    A new support case has been filed with Microsoft as they have seemingly stopped responding to the previous support case.

    Previous workaround remains in place, but is not perfect. Please notify me if you are encountering any issues sending mail to any addresses, and especially to @outlook.com or @hotmail.com or @live.com addresses. Thank you.

  • Monitoring
    Update

    Workaround remains in place. Microsoft is still working on the issue on their side.

  • Monitoring
    Update

    I am continuing to monitor. Microsoft has not yet fixed the problem on their side, so I have left the workaround in place for now.

  • Monitoring
    Monitoring

    I have implemented a workaround and am monitoring the situation. When Microsoft fixes the issue on their end, I will revert the workaround slowly to ensure it's working correctly again.

    If you have any email failures to @outlook.com or @hotmail.com addresses, please contact me right away to investigate further.

  • Identified
    Identified

    I have identified the issue, but this is something Microsoft has to fix, so I am at their mercy. I have a ticket opened with them which they are working on.

  • Investigating
    Investigating

    I am aware of some users who are having issues sending to any Microsoft-owned emails (such as to @outlook.com or @hotmail.com addresses) from my mail servers. I am currently investigating and working on a resolution.